import Foundation
let pattern = #"^[\d_-]*[a-zA-Z][-\w]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
ecK3EnyGD8o
1s3get2-3ds
4bc2qfs2wrf
28yq389gfwg
3oyh8pw489p
abcdefghijk
abcde-fghi_jk
12345678910
18974107892351240891751928347819234
Stack Overflow
kjsad;kflj;klasdfkjalk;sdfjlkas
!&$@#)&&()%&*(#@$&(
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)