#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m-s)(?:^(?=.*\bbar\b)|(?!^)\G).*?\K[ ]{2}"
Local $sString = "foo: here is some sample text" & @CRLF & _
"bar: here is some sample text" & @CRLF & _
"" & @CRLF & _
"The closest that I've gotten has been using this:" & @CRLF & _
""
Local $sSubst = "\\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)