$re = '/(?m-s)(?:^(?=.*\bbar\b)|(?!^)\G).*?\K[ ]{2}/';
$str = 'foo: here is some sample text
bar: here is some sample text
The closest that I\'ve gotten has been using this:
';
$subst = "\\t";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;