package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https?:\/\/)?(?:www\.)?(?:[a-zA-Z0-9][-a-zA-Z0-9%_\+~#=]*\.)+[a-zA-Z][a-zA-Z0-9]{0,6}(?:/[a-zA-Z0-9_%+=~\-]+\.)*(?:#(?:[a-zA-Z][a-zA-Z0-9]+=[a-zA-Z0-9]*,)*(?:[a-zA-Z][a-zA-Z0-9]+=[a-zA-Z0-9]*))?`)
var str = `google.com/dreg...greg..ergtrg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}