use strict;
my $str = 'cat:others;id:4,9,13;id:4,9,13;cat:electric-products;id:4,9,13;cat:foods;cat:drinks,foods';
my $regex = qr/(?:^|;)(id|cat):|\G(?!^),?([^,;]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}