import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([[a-zA-Z\\p{L}\\.\\-']{1,30})(\\s))(([a-zA-Z\\p{L}\\.\\-']{1,30})(\\s))?([[a-zA-Z\\p{L}\\.\\-']{1,30})(\\s)?(\\([a-zA-Z\\p{L}\\.\\-'\\s]{1,50}\\))?$";
final String string = "Robert Alvarez\n"
+ "Yvonne Andersen\n"
+ "Bob Anderson (director)\n"
+ "Mike B. Anderson\n"
+ "Stephen Anderson (artist)\n"
+ "Joel Zwick\n"
+ "Terry Zwigoff\n"
+ "Andrzej Żuławski\n"
+ "Xawery Żuławski\n"
+ "Harald Zwart\n"
+ "Ezz El-Dine Zulficar (potate)\n"
+ "Irvin S. Yeaworth Jr.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}