const regex = new RegExp('^(([[a-zA-Z\\p{L}\\.\\-\\']{1,30})(\\s))(([a-zA-Z\\p{L}\\.\\-\\']{1,30})(\\s))?([[a-zA-Z\\p{L}\\.\\-\\']{1,30})(\\s)?(\\([a-zA-Z\\p{L}\\.\\-\\'\\s]{1,50}\\))?$', 'gm')
const str = `Robert Alvarez
Yvonne Andersen
Bob Anderson (director)
Mike B. Anderson
Stephen Anderson (artist)
Joel Zwick
Terry Zwigoff
Andrzej Żuławski
Xawery Żuławski
Harald Zwart
Ezz El-Dine Zulficar (potate)
Irvin S. Yeaworth Jr.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}