Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
@"
^(([[a-zA-Z\p{L}\.\-']{1,30})(\s))(([a-zA-Z\p{L}\.\-']{1,30})(\s))?([[a-zA-Z\p{L}\.\-']{1,30})(\s)?(\([a-zA-Z\p{L}\.\-'\s]{1,50}\))?$
"
gm
Input 1
1
New
Robert Alvarez Yvonne Andersen Bob Anderson (director) Mike B. Anderson Stephen Anderson (artist) Joel Zwick Terry Zwigoff Andrzej Żuławski Xawery Żuławski Harald Zwart Ezz El-Dine Zulficar (potate) Irvin S. Yeaworth Jr.