package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<mm>\b(?:1[0-2]|[1-9])\b)`)
var str = `1
2
3
4
5
6
7
8
9
10
11
12
13
some text with a 12 in it and a 13 also`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}