# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^'` \"\n]+)\.([^ \n]+)&([^ \"`'\n]+)(?![\"'])"
test_str = ("www.google.com/mom=3&f\n"
" -H \"Content-Type: google.com/cool?cool1=yes&cool2=no&cool3=no\" \\\\\n"
"-H \"Content-Type: google.com/cool?mom=3&f\" \\\\\n"
"www.google.com/mom=3&fbom=cbom'\n"
"\"www.google.com/mom=3&f\"\n"
"curl -X GET \\\\\n"
" -H \"User-Agent: Dalvik/2.1.0 (Linux; U; Android 10; SM-A705FN Build/QP1A.190711.020) Test/4.6.4.459\" \\\\\n"
" -H \"Authorization: bearer XXX\" \\\\\n"
" -H \"x-storefront-id: 1\" \\\\\n"
" -H \"x-application-id: 5\" \\\\\n"
" -H \"Build: 4.6.4.459\" \\\\\n"
" -H \"Platform: Android\" \\\\\n"
" -H \"Gender: M\" \\\\\n"
" -H \"SearchSegment: 98\" \\\\\n"
" -H \"OSVersion: 10\" \\\\\n"
" -H \"DeviceId: b147ee89\" \\\\\n"
" -H \"pid: bdb5748e\" \\\\\n"
" -H \"sid: 5096fd6e\" \\\\\n"
" -H \"x-features: FEATURE1_ENABLED\" \\\\\n"
" -H \"Accept-Language: tr-TR\" \\\\\n"
" -H \"Content-Type: google.com/cool?cool1=yes&cool2=no&cool3=no\" \\\\\n"
" google.com/cool?cool1=yes&cool2=no&cool3=no`\n\n"
"/^((?!hede).)*$/s\n"
"^(?:(?!:hede).)*$\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.