const regex = /(\w+\s+\d+|\(?\d{4}\)?|[a-z]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+\\s+\\d+|\\(?\\d{4}\\)?|[a-z]+)', 'gmi')
const str = `全新Precision 5530二合一移动工作站
15" (5530)
新14"灵越燃7000三边微边框
灵越新13"(7380)轻薄本 热卖
XPS新15"(9570)热卖
新15"灵越5000(Intel)
12” 二合一 (5290)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}