using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""(?<job_ids>(?:\w+-\w+-\w+-\w+-\w+)+),?\""";
string input = @"{""JobIds"":[""661ce07c-b5f3-4b37-8b4c-a0b76d890039"",""db7a18ae-ea59-4987-87d5-c80adefa4475""]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}