use strict;
my $str = '123456_123456
12345678_12345678_12345678
123456_12345678_123456_12345678
12345_123456_1234567_12345678_
12334_
123456_1
123456_12
123456_1594126781
123_1594126781';
my $regex = qr/^\d{5,8}(?:_\d{5,8})+_?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}