using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\*([a-zA-Z0-9]+)_START\*\/(.*?)\/\*(\1)_END\*)";
string input = @"/*tag1_START*/ some content /*tag1_END*/ other text /*tag2_START*/ some content /*tag2_END*
/*tag3_START*/ some /*tag4_START*/ content /*tag3_END*/ other /*tag4_END*/ content";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}