import Foundation
let pattern = #"(?=\*([a-zA-Z0-9]+)_START\*\/(.*?)\/\*(\1)_END\*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/*tag1_START*/ some content /*tag1_END*/ other text /*tag2_START*/ some content /*tag2_END*
/*tag3_START*/ some /*tag4_START*/ content /*tag3_END*/ other /*tag4_END*/ content
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)