$re = '/[A-z]*[Aa][A-z]*[Rr][A-z]*|[A-z]*[Rr][A-z]*[Aa][A-z]*/';
$str = 'Maria xxx Paul xxx Taylor xxx Henry xxx Ray xxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);