$re = '/((https?:\/\/)|(\/)|(..\/))(\w+:{0,1}\w*@)?(\S+)(:[0-9]+)?(\/|\/([\w#!:.?+=&%@!\-\/]))?/m';
$str = 'https://www.test.com
https://test.com
http://www.test.com
http://test.com
https://test.com/123
https://test.com/123/456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);