package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<span class="booking-id-value">(.+)<\/span>`)
var str = `foo
<span class="booking-id-value">U166097</span>
bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}