$re = '/<span class="booking-id-value">(.+)<\/span>/';
$str = 'foo
<span class="booking-id-value">U166097</span>
bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);