#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^r\d+---sn-vgqs[a-z0-9]{4}\.googlevideo\.com$"
Local $sString = "r4---sn-vgqsrnez.googlevideo.com" & @CRLF & _
"r1---sn-vgqsknlz.googlevideo.com" & @CRLF & _
"r5---sn-vgqskn7e.googlevideo.com" & @CRLF & _
"r3---sn-vgqsknez.googlevideo.com" & @CRLF & _
"r6---sn-vgqs7ney.googlevideo.com" & @CRLF & _
"r4---sn-vgqskne6.googlevideo.com" & @CRLF & _
"r4---sn-vgqsrnez.googlevideo.com" & @CRLF & _
"r5---sn-vgqskn76.googlevideo.com" & @CRLF & _
"r6---sn-vgqs7ns7.googlevideo.com" & @CRLF & _
"r1---sn-vgqsener.googlevideo.com" & @CRLF & _
"r1---sn-vgqskn7z.googlevideo.com" & @CRLF & _
"r1---sn-vgqsknek.googlevideo.com" & @CRLF & _
"r6---sn-vgqsener.googlevideo.com" & @CRLF & _
"r3---sn-vgqs7nly.googlevideo.com" & @CRLF & _
"r1---sn-vgqsknes.googlevideo.com" & @CRLF & _
"r4---sn-vgqsrnes.googlevideo.com" & @CRLF & _
"r6---sn-vgqskn76.googlevideo.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")