import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-?[.0-9]+)\\^(-?[.0-9]+)";
final String string = "5^2\n"
+ "8*6^-8\n"
+ "7/6^8+7\n"
+ "7/1.5^8+7-8\n"
+ ".4^0.4\n"
+ ".4+^0.4 (invalid)\n"
+ "5400^.5+2\n"
+ "4.^.5";
final String subst = "Math.pow(\\\\1, \\\\2)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}