$re = '/\b([A-Z]{2})[-\s](20[0-9]{2}|2100)-(0?[1-9]|1[0-2])-(\d{6})(?!\d)/m';
$str = 'any text CA-2019-6-000000 any text
any text KA 2019-2-929029
KA-2019-11-929029';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);