#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^\s=]+)\h+=\h+(.*(?:\R(?![^\s=]+\h+=\h+).*)*)$"
Local $sString = "groupid = foo" & @CRLF & _
"location = westus" & @CRLF & _
"randomkey = fbae3700c34cb06c" & @CRLF & _
"resourcename = example4-resourcegroup" & @CRLF & _
"tls_private_key = -----BEGIN RSA PRIVATE KEY-----" & @CRLF & _
"//stuff" & @CRLF & _
"-----END RSA PRIVATE KEY-----" & @CRLF & _
"" & @CRLF & _
"foo = 123" & @CRLF & _
"faa = 223"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")