using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"simulate\(\w+, \[\n\s+\{\n\s+type: ""(\w+)"",\n\s+target: ""\[data-test-id=([\w-]+)\]"",\n\s+},\n\s+\]\);";
string input = @" simulate(component, {
type: ""click"",
target: ""[data-test-id=filterMenu-owner]"",
});
simulate(component, {
type: ""click"",
target: ""[data-test-id=filterMenu-ownerUser]"",
});
simulate(filterMenuPopup, [
{
type: ""click"",
target: ""[data-test-id=ownerGroup-item-8370094050639872]"",
},
]);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}