#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^|, )dog|cat(?=$|,)"
Local $sString = "dog, cat" & @CRLF & _
"dog, dog, cat" & @CRLF & _
"dog, dog, dog" & @CRLF & _
"dog, dog, dog, cat" & @CRLF & _
"dog, dog, dog, dog, cat" & @CRLF & _
"dog, dog, dog, dog, dog" & @CRLF & _
"dog, dog, dog, dog, dog, cat" & @CRLF & _
"dog, dog, dog, dog, dog, dog, dog, cat" & @CRLF & _
"dog, dog, dog, dog, dog, dog, dog, dog, dog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")