re = /(?si).*Invoice[\s_:.]+(?<anr>[^\s_]+).+/m
str = 'Payer:_xxxxxxx
Waybill Invoice_IN280625-3/4 Nimetus_EAN
Invoice issuer: John
Selle Invoice tasumisel palume m lisada Kesolev Invoice on poolte
vahel Invoice mittetähtaegsel tasumisel on müüjal õigus nõuda viivist 0,1% tasumata summalt päevas.
Kuni Invoice payment sumiseni k
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end