package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)reg(?:(ic)|ex)(?(1)es|(?:es)?)`)
var str = `regexes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}