#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\$2[ayb]\$.{56}$"
Local $sString = "$2a$abcdefghij1234567890abcdefghij1234567890abcdefghij123456" & @CRLF & _
"$2b$abcdefghij1234567890abcdefghij1234567890abcdefghij123456" & @CRLF & _
"$2y$abcdefghij1234567890abcdefghij1234567890abcdefghij123456" & @CRLF & _
"" & @CRLF & _
"$2z$abcdefghij1234567890abcdefghij1234567890abcdefghij123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")