#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)rtl_433\/r4-64\/devices\/([^\/:]+)\/([^\/:]+).*:.*"
Local $sString = "rtl_433/r4-64/devices/AmbientWeather-TX8300/1/108/mic:" & @CRLF & _
"rtl_433/r4-64/devices/AlectoV1-Wind/1/36/mic:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")