$re = '/rtl_433\/r4-64\/devices\/([^\/:]+)\/([^\/:]+).*:.*/m';
$str = 'rtl_433/r4-64/devices/AmbientWeather-TX8300/1/108/mic:
rtl_433/r4-64/devices/AlectoV1-Wind/1/36/mic:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);