$re = '/^(.+?)\ bag[s]?\ contain\ (?:(?:[1-9]\ (.+?)\ bag[s]?)(?:,\ [1-9]\ (.+?)\ bag[s]?)*|(?:no\ other\ bags)).$/m';
$str = 'dotted indigo bags contain 5 dotted lavender bags, 5 shiny gold bags, 1 vibrant tomato bag, 1 striped purple bag.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);