package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\s*میلیون`)
var str = `منزل۲۲۰ متری دونبش کلنگی ۲۰ سال ساخت سند شش دانگ واقع در چهارراه دولت آباد قیمت ۲۸۰ میلیون تومان`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}