import Foundation
let pattern = #"\d+(*SKIP)(?:\.\d+)?(?=\s*руб\.)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Бронирование № 372 12343.22 от 24 июня 21. Стоимость проживания 1000.32 руб. а так же комиссия в размере 500 руб."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)