#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\+?([ -]?\d+)+|\(\d+\)([ -]\d+)"
Local $sString = "+62 361 222777" & @CRLF & _
"+62 813-444-5555 " & @CRLF & _
"+62 812-3333-3333" & @CRLF & _
"+62 811 391 2103 " & @CRLF & _
"+62 361-2277777" & @CRLF & _
"(0361) 227337" & @CRLF & _
"+62 8113912103" & @CRLF & _
"08134455555" & @CRLF & _
"0361-2277777" & @CRLF & _
"+62 812 3333 3333" & @CRLF & _
"+62 877 80803550" & @CRLF & _
"081339222111" & @CRLF & _
"081 339 222 111" & @CRLF & _
"+62 811338429196"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")