# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d)\s*\.\d+\././gm;t' <<< "remove 1 from .1.
XYZ is a student.2. XYZ is a boy.3. XYZ is smart.
This is a test value 1.1.
127.0.0.1"