#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\d)\s*\.\d+\."
Local $sString = "remove 1 from .1." & @CRLF & _
"XYZ is a student.2. XYZ is a boy.3. XYZ is smart." & @CRLF & _
"This is a test value 1.1." & @CRLF & _
"" & @CRLF & _
"127.0.0.1"
Local $sSubst = "."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)