// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([Aa]cestream:\/\/|http:\/\/127\.0\.0\.1:6878\/ace.*\?.*=)([a-z,0-9]{40})").unwrap();
let string = "acestream://4b9a3382d30af6588d484e92377629ce3b6a32da
acestream://4a3286ad2718d35a55bfb81da22c5d04aad42e29
http://127.0.0.1:6878/ace/getstream?infohash=01670d76bdc01781c122695b96093b4cbfdacc3b";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}