import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:ht|f)tp(?:s?)\\:\\/\\/|~\\/|\\/)?(?:\\w+:\\w+@)?((?:(?:[-\\w\\d\\{1-3\\}]+\\.)+(?:com|org|net|gov|mil|biz|info|mobi|name|aero|jobs|edu|co\\.uk|ac\\.uk|it|fr|tv|museum|asia|local|travel|[a-z]{2}))|((\\b25[0-5]\\b|\\b[2][0-4][0-9]\\b|\\b[0-1]?[0-9]?[0-9]\\b)(\\.(\\b25[0-5]\\b|\\b[2][0-4][0-9]\\b|\\b[0-1]?[0-9]?[0-9]\\b)){3}))(?::[\\d]{1,5})?(?:(?:(?:\\/(?:[-\\w~!$+|.,=]|%[a-f\\d]{2})+)+|\\/)+|\\?|#)?(?:(?:\\?(?:[-\\w~!$+|.,*:]|%[a-f\\d{2}])+=?(?:[-\\w~!$+|.,*:=]|%[a-f\\d]{2})*)(?:&(?:[-\\w~!$+|.,*:]|%[a-f\\d{2}])+=?(?:[-\\w~!$+|.,*:=]|%[a-f\\d]{2})*)*)*(?:#(?:[-\\w~!$ |\\/.,*:;=]|%[a-f\\d]{2})*)?\\b";
final String string = "# valid\n"
+ "http://www.google.com\n"
+ "ftp://example.com\n"
+ "google.com\n"
+ "a.google.com\n"
+ "a.google.com/b/~user\n"
+ "http://www.google.com/~user\n"
+ "www.google.com/sdfa/asdf?f93+3234\n"
+ "accounts.google.com\n"
+ "valid.domain.com/foasdf/~23423lj\n"
+ "accounts.google.com/login?res=sdfs sdf\n"
+ "accounts.google.com\n"
+ "you.name\n"
+ "you.name/~joe\n"
+ "google.com/+joe\n"
+ "https://joe:test@test.com\n\n"
+ "# partial \n"
+ "http://joe@test.com\n\n\n"
+ "# invalid\n"
+ "not: \n"
+ "ftp://example\n"
+ "something.asfdasjdlf;\n"
+ "abc.def@#$90fai\n"
+ "something.like.this\n"
+ "abc.def\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}