$re = '/getopt(?:s|)(?: (?:-[a-zA-Z])*)*(?\'name\'[$a-zA-Z]+|)\s(?:(?:-o|--options) (?\'short\'.+) (?:-l|--longoptions|--long) (?\'long\'(?:[a-zA-Z0-9]|,|:|\$)+) \-\- \"\$@\"|(?:(?:(?:-[a-zA-Z])*|)\s*\"(?\'while\'(?:[a-zA-Z0-9]|,|:|\$)+)\"))/m';
$str = 'while getopts -a ":n:t:" options; do
while getopts -a -n ":n:t:" options; do
while getopt ":n:t:" options; do
Parameters=$(getopt -a -n $ScriptName --options $SHORT --longoptions $LONG -- "$@")
Parameters=$(getopt -a -n alphabet -o abc:d: --long alpha,bravo,charlie:,delta: -- "$@")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);