#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).*?"id": (\d+).*?("exclusions": \[.*?|"desig").*?{"
Local $sString = " {" & @CRLF & _
" "id": 5229," & @CRLF & _
" "Type": B," & @CRLF & _
" "exclusions": [" & @CRLF & _
" {" & @CRLF & _
" "id": 3486," & @CRLF & _
" "desig": "A"," & @CRLF & _
" "price": 101," & @CRLF & _
"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "id": 3489," & @CRLF & _
" "desig": "A"," & @CRLF & _
" "price": 101," & @CRLF & _
" }]}," & @CRLF & _
"" & @CRLF & _
" {" & @CRLF & _
" "id": 5239," & @CRLF & _
" "Type": B," & @CRLF & _
" "exclusions": []" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")