$re = '/.*?"id": (\d+).*?("exclusions": \[.*?|"desig").*?{/s';
$str = ' {
"id": 5229,
"Type": B,
"exclusions": [
{
"id": 3486,
"desig": "A",
"price": 101,
},
{
"id": 3489,
"desig": "A",
"price": 101,
}]},
{
"id": 5239,
"Type": B,
"exclusions": []
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);