$re = '/^[a-zA-Z0-9_-]+=>[a-zA-Z0-9_-]+$/m';
$str = 'Field=>Value-True
=>False_name
Bad_name_2=>
=>
=>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);