use strict;
my $str = 'WEEK = \'2\'
Date_Number(3,4,5,6,7,8)
AND
Allowance=\'100\'
AND
((End_Date<\'2017-09-17 00:00:00\'
AND
Saturday_Name)';
my $regex = qr/Date_Number\(.*\)/p;
my $subst = 'Date_Number(22,25,27,28,29)';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";