// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Date_Number\(.*\)").unwrap();
let string = "WEEK = '2'
Date_Number(3,4,5,6,7,8)
AND
Allowance='100'
AND
((End_Date<'2017-09-17 00:00:00'
AND
Saturday_Name)";
let substitution = "Date_Number(22,25,27,28,29)";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}