import Foundation
let pattern = #"Date_Number\(.*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
WEEK = '2'
Date_Number(3,4,5,6,7,8)
AND
Allowance='100'
AND
((End_Date<'2017-09-17 00:00:00'
AND
Saturday_Name)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Date_Number(22,25,27,28,29)"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}