using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bsensitivity\s*""(\d+)""";
string input = @"zoom_sensitivity ""2""
sensitivity ""99""
m_rawinput ""0""
m_righthand ""0""
also with different spacing:
sensitivity""99""m_rawinput""0""zoom_sensitivity""2""m_righthand""0""
another example:
sensitivity""99"" m_rawinput ""0""
m_righthand ""0""
zoom_sensitivity""2""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}