// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\bsensitivity\s*"(\d+)""#).unwrap();
let string = "zoom_sensitivity \"2\"
sensitivity \"99\"
m_rawinput \"0\"
m_righthand \"0\"
also with different spacing:
sensitivity\"99\"m_rawinput\"0\"zoom_sensitivity\"2\"m_righthand\"0\"
another example:
sensitivity\"99\" m_rawinput \"0\"
m_righthand \"0\"
zoom_sensitivity\"2\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}