#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^|\s*(;))\s*[\d.]+\s*"
Local $sString = "2 MG/ML" & @CRLF & _
"500 MCG" & @CRLF & _
"100 MG ; 200 MG ; 200 MCG" & @CRLF & _
"100 MCG/ML" & @CRLF & _
"325 MG ; 37.5 MG" & @CRLF & _
"60 G ; 9 G/1000 ML"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)