package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|\s*(;))\s*[\d.]+\s*`)
var str = `2 MG/ML
500 MCG
100 MG ; 200 MG ; 200 MCG
100 MCG/ML
325 MG ; 37.5 MG
60 G ; 9 G/1000 ML`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}