re = /(?i)(?<!\b[01][0-9])(?<!\b[2][0-3])([^\S\r\n]*:)[^\S\r\n]*(?![0-5][0-9](?:[ap]\.?m\b\.?)?)/
str = 'am
pm
P.M.
10:56pm : start a new line
10:43 a.m.'
subst = '\\1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result